Blog 2018-04-10T19:58:35+00:00

Weg mit dem Virenscanner? Nein – Windows Defender reicht NICHT!

Momentan gibt es verschiedene Beitrage in den Mainstream-Medien, die erklären, dass man einen Virenscanner nicht mehr benötigt, da im Windows 10 der Windows Defender enthalten sei – und dieser würde ausreichen.  Darüberhinaus wird sogar vor Virenscannern gewarnt, diese seien sogar gefährlich.

Ein Beispiel:

http://www.faz.net/aktuell/technik-motor/digital/so-schueren-virenscanner-unbegruendet-panik-15755688.html

 

Die Realität sieht leider ganz anders aus:

Beispiel: Email von heute morgen – angeblich von Hanna Sommer:

im Anhang dieser Email befindet sich die Datei “Hannah Sommer – Bewerbung und Lebenslauf 03.09.2018.exe” die der Windows Defender von Microsoft nicht beanstandet.

Lässt man diese Datei jedoch von anderen Virenscannern prüfen, so sieht das Ergebnis schon ganz anders aus:

Quelle: https://www.virustotal.com/#/file/4700a6af33a5c5052ea0598b74395d4e8086956ea4e1cb2fe730f1807f760da3/detection

Die namhaften Hersteller wie Sophos, Kaspersky und Symantec erkennen den Virus. Während Microsoft und einige andere (z.B. F-Secure, Gdata und Trendmiro) noch im Dunkeln tappen.

By | 03.09.2018|Categories: Allgemein|0 Comments

Warum ein Reboot kein Reboot mehr ist

Alles gut macht der Reboot? Das stimmt leider nicht mehr….

Vielleicht kennen Sie das ja:

  • Die Drucker auf Ihrem Computer funktionieren nicht mehr richtig
  • Ihr Outlook macht Probleme
  • VPN Verbindungen funktionieren nicht mehr richtig
  • ….

Schauen Sie mal in Ihren Task-Manager unter CPU auf den Wert für die Betriebszeit:

34 Tage Betriebszeit – obwohl Sie Ihren Computer jeden Tag herunterfahren?

Die Ursache für diesen Verhalten nennen Microsoft “Fastboot” oder auch “Schnellstart”. Diese Einstellung die Windows 10 per Default hat führt dazu, dass Ihr Betriebssystem nicht wirklich neu startet – auch wenn Sie Ihren Computer korrekt herunterfahren.

Eingeführt wurde es mit Windows 8 und Microsoft erklärt den Unterschied so:

Der Vorteil: Ihr Computer fährt wesentlich schneller hoch und auch runter

Nachteil: Wichtige Updates werden nicht mehr zeitnah installiert, Gruppenrichtlinien werden nicht mehr ausgeführt und das ganze System wird nicht mehr richtig auf “Null” gesetzt.

Was können Sie tun?

Soforthilfe: Machen Sie einen “richtigen” Neustart. Halten Sie hierzu die Shift-Taste gedrückt werden Sie auf Herunterfahren klicken. Ihr Computer wird daraufhin vollständig herunterfahren.

Dauerhaft: Schalten Sie den Fastboot aus. Hierzu gehen Sie in die klassische Systemsteuerung unter Energieoptionen und klicken dort auf “Auswählen, was beim Zuklappen des Computers geschehen soll”:

Danach deaktivieren Sie diese Option:

By | 08.03.2018|Categories: Allgemein|Tags: , |0 Comments

Erinnerung an Watchguard-Kunden: Upgrade auf Firmware 12.x notwendig

Wir möchten alle Watchguard Kunden darin erinnern, dass ein Upgrade der Firmware auf Version 12.x notwendig ist, da der Support für die Virenscanner-Engine von AVG zum 15.4.2018 ausläuft.

Hintergrund: Watchguard hat mit der Firmware 12.0 von AVG zu Bitdefender gewechselt (Quelle: https://www.watchguard.com/wgrd-blog/fireware-120-now-available)

Es wird auch nach dem 15.4.2018 noch für einige Monate Virenpattern-Updates für die Firmware 11.x verteilt werden, jedoch empfehlen wir dringend den Wechsel zu aktuellen 12.1 Firmware.

Infos zur aktuellen Firmware 12.1.1: https://www.watchguard.com/wgrd-blog/fireware-1211-now-available

By | 16.02.2018|Categories: Watchguard|Tags: , , |0 Comments

Fritzbox 6490 im Bridge Modus (Fritz!OS 06.63)

Nachdem an unserem Unitymedia Anschluss das Cisco Kabelmodem kaputt war, brauchten wir ein neues Kabel-Modem damit wir die Watchguard als Firewall daran hängen konnten. Der Unitymedia Support empfahl mit eine Fritzbox zu kaufen, da diese den Bridge Modus beherrschen.

Leider stimmt diese Aussage nicht mehr, da die aktuelle Fritzbox 6490 mit Fritz!OS 06.63 den Bridge Modus nicht mehr zur Verfügung stellt….

Nun eigentlich…. man kann diese doch noch aktivieren.

  1. Man sichert die Config der Fritzbox unter System->Sicherung lokal auf einen Rechner.
  2. Den Eintrag “lanbridges_gui_hidden = yes;” ändern man entsprechend mit einem Texteditor ab zu “lanbridges_gui_hidden = no;”
  3. Für den gesamten Text muss man dann eine neue Checksumme berechnen lassen – das geht z.B. hier: http://www.mengelke.de/Projekte/FritzBoxJSTool
  4. Den neuen Wert trägt man dann in der letzten Zeile ein (**** END OF EXPORT XZY123 ****) und speichert die Datei wieder.
  5. Diese modifizierte Config lädt man dann in die Fritzbox hoch und führt einen Neustart durch

Und siehe da:

Entsprechenden LAN Port auswählen und dann die Firewall daran anschließen. Per DHCP erhält man dann eine externe IP.

Aber Vorsicht: Die Fritzbox zieht sich natürlich auch eine IP -d.h. hat man einen Tarif mit nur einer externen IP Adresse, dann wird auch nur diese geroutet.

In einem solchen Fall ist die Konfiguration als Exposed Host ratsam.

By | 04.01.2018|Categories: Allgemein|0 Comments

Exchange 2016 – 4096 (0x1000) is an invalid culture identifier

Für einen Kunden habe ich eine Exchange 2016 Organisation mit drei Exchange Servern aufgebaut.

Auf den Windows 10 Computern bekamen aber alle Benutzer folgende Fehlermeldung, sobald Sie OWA mit IE oder Edge öffnen wollten:

Auf dem betroffenen Exchange 2016 Server (CU6 und CU7) kam jeweils folgende Fehlermeldung im Systemprotokoll:

MSExchange Front End HTTP Proxy - EventID 1003

[Owa] An internal server error occurred. The unhandled exception was: System.Globalization.CultureNotFoundException: Culture is not supported.
 Parameter name: culture
 4096 (0x1000) is an invalid culture identifier.
    at System.Globalization.CultureInfo.InitializeFromCultureId(Int32 culture, Boolean useUserOverride)
    at Microsoft.Exchange.Net.ClientCultures.GetCultureInfoInstance(Int32 lcid)
    at Microsoft.Exchange.Net.ClientCultures.GetBrowserDefaultCulture(HttpRequestBase httpRequest)
    at Microsoft.Exchange.Clients.Owa.Core.OwaPage.InitializeCulture()
    at ASP.auth_errorfe_aspx.__BuildControlTree(auth_errorfe_aspx __ctrl)
    at ASP.auth_errorfe_aspx.FrameworkInitialize()
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at System.Web.UI.Page.ProcessRequest()
    at System.Web.UI.Page.ProcessRequest(HttpContext context)
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Interessanterweise kam die Meldung aber nur beim Zugriff auf die Exchange 2016 Server die auf Windows 2016 Server installiert waren. Der Zugriff auf den Exchange 2016, welcher auf Windows 2012 R2 installiert, war funktionierte einwandfrei.

Auch der Zugriff von externen Windows 10 Computern oder mit Firefox oder Chrome funktionierte einwandfrei.

Versucht wurde:

  • Installation aller aktueller Windows Updates
  • Umstellen der Mailbox-Default Sprache der betroffen User
  • Update der Exchange Server auf CU7
  • Update Windows von 1706 auf 1709

Ohne Verbesserung.

Bei der weiteren Fehlersuche fiel mir auf, dass im Windows 10 eine sehr merkwürdige Sprachauswahl English (en-DE) stand:

Lösung:

Nach der Korrektur der Sprachauswahl trat der Fehler nicht mehr auf. Interessanterweise kann man nachträglich diese Spracheauswahl auch nicht mehr auswählen:

Ursachenforschung:

Bei der Installation der Windows 10 Rechner wurde immer eine englische Evaluations ISO von Windows 10 genommen, als Tastatur aber Deutsch und als Region Deutschland ausgewählt. Somit kam “English (de-EN)” zustande.

Laut Microsoft (Quelle https://msdn.microsoft.com/en-us/library/ee825488(v=cs.20).aspx) gibt es diese “Culture” aber gar nicht.

Wieso kommt bei Windows Server 2016 eine Fehlermeldung aber bei Windows Server 2012 R2 nicht?

Die Powershell Abfrage system.Globalization.CultureInfo]::GetCultures(‘AllCultures’)  ergibt beim Windows 2016 Server:

D.h. diese Culture-Auswahl ist bekannt, ergibt aber 4096

Bei einem Windows 2012 R2 Server fehlt diese:

Fazit

Meiner Meinung nach handelt es sich also um einen Bug im Windows 1706 und 1709, da eine scheinbar ungültige Sprachkombination English (en-DE) im System eingetragen wird. Diese wird dann von IE und vom Edge an den OWA übertragen,  der damit dann aber nicht anzufangen weiss. Ergo Fehlermeldung.

Auf einem Windows 2012 R2 Server kommt es zu der Fehlermeldung nicht, da der Server diese Kombination nicht kennt und somit ignoriert.

 

By | 30.10.2017|Categories: Allgemein|0 Comments

No Minimal Required Number of Suitable Directory Servers Found in Forest

Ausgangssituation

Nach einem Exchange 2013 Crash dank ESXI 6.0 musste ich eine Recovery-Installation durchführen.

Während der Neu-Installation des Exchange 2013 brach diese jedoch immer wieder mit Folgender Fehlermeldung ab:

Prozess Microsoft.Exchange.Directory.TopologyService.exe (PID=4772) Gesamtstruktur xxxxx.local. Fehler bei der Topologieerkennung, Fehlerdetails

No Minimal Required Number of Suitable Directory Servers Found in Forest xxxxx.local Site Standardname-des-ersten-Standorts and connected Sites..

Die Domäne hatte schon immer nur einen Domain-Controller, von daher war die Meldung erstmal unverständlich.

Verschiedene Seiten und Blogs empfehlen in diesem Fall den Wert

MinSuitableServer = “1”  in in der Microsoft.Exchange.Directory.TopologyService.exe.config zu ändern.  Aber auch das brachte keine Veränderung.

Letztendlich habe ich einen zweiten DC installiert – aber auch dies brachte keine Veränderung. Die Fehlermeldung blieb.

Die Lösung

Zielführend war folgende Seite:

https://bloke.org/windows/exchange-2003-2007-2010-topology-discovery-failed-error-0x80040a02-dsc_e_no_suitable_cdc/#comment-3982

Der Zusammenhang war zwar ein anderer, aber das beschriebene Problem war das gleiche: In der Default Domain Controllers Policy hat unter

Computer Configuration ->Windows Settings -> Security Settings ->Local Policies -> User Rights Assignment  beim “Mange auditing and security log” der Eintrag “Exchange Servers” gefehlt (Warum auch immer in diesem Fall….)

Das heißt, der Exchange-Server hatte nicht das Recht auf die Auditing und Security Logs des Domain-Controllers zuzugreifen und das Installationsprogramm interpretierte dies mit der Meldung, dass nicht genügend Domain-Controller verfügbar waren – was natürlich kompletter Quatsch war.

Nachdem das korrigiert war, lief die Installation ohne Probleme durch.

By | 21.09.2017|Categories: Allgemein|0 Comments